HELP – Nexus 4 does not Recieve MMS with Wifi on…

Posted Apr 28, 2013 at 2:28 pm in Threads > Smartphones & Tablets

I have searched around and it seems like a few people have this issue.

When I have Wifi turned on I do not receive MMS (pictures). I can turn off my Wifi and boom, I get pictures sent to my phone that can be 3-4weeks old.

Is this is an issue with the phone, Android 4.2.2 or my carrier, Bell?

I am using stock Android and the stock messaging system.

Any input is appreciated.

Thanks!

  • Mix

    Any ideas?

    • http://androidandme.com Taylor Wimberly

      Haven’t seen this before. Are you using the default messaging app or some 3rd party one? Have you tried resetting your APN settings?

  • Mix

    I am using the default messaging app and have not reset my APN setting.

    I will try that out and see if it makes a difference – will report back once a friend tries to send me a pic.

  • Mix

    Late reply but it turns out that fixed my problem!

    I had a buddy test and I received 6 photo’s no problem, thanks!!

  • anonymous

    modify your apn, add a duplicate of whatever you already have, “apn type” probably says “default ” or perhaps “*” or maybe “default,supl,mms ”

    remove mms from the default, then in the duplicate apn, change it to say just “mms”

    you will have two apns, but the second one does not have a radio check mark, it will use the first one for everything and for mms it will use the second one.

    the problem is that wifi routes everything through wifi including mms. doing it this way routes everything but mms through wifi.