Play Store crashing instantly

Posted Dec 30, 2012 at 11:06 am in Threads > Apps

I’m running 4.1.2 on a Nexus S, and my Play Store keeps crashing instantly on launch. I’ve done several reboots, but no dice.

Anyone else have this issue or have had it in the past? Any tips on how I can fix it?

I’ve also force stopped the app several times, but again, nothing.

  • redraider133

    Maybe try clearing cache and app data for the play store?

    • VerticalCobra

      This is the usual remedy for FC on android

      • Taylor

        I need help my Samsung galaxy epic 4g is rooted and I did a update to my phone, and after the update Google play would say a message to me than I reset it to factory settings and I’ve done many different things to get it to work. And nothing is working at all :/ I’ve been using the phone for about a month and a week ago it quit working so I went back to using my iPod touch

        • anwar

          I think it u more gut have bricked it not to worry email me n I’ll have it hopefully back up n running

          • court

            I need help my Google play store keeps giving me an error message saying unfortunately it has stopped I have tried everything I can imagine like clearing cache nothings working

    • Richard Whereat

      I would love to. It doesn’t give me the chance to do that. It crashes instantly.

      • gmaninvan

        You don’t need to get into the app to do that. Go to settings>apps

        Then find the play store. In there you can clear everything. This can solve a lot of issues. I am not sure why his comment got so downvoted.

        • Darlene

          I did have a problem finding Pay Store.
          It was not in my apps but did find it in an instant with your answer but not sure if it worked yet…shut down and will hope when I restart it will work.

      • gmaninvan

        You can also roll it back a version

    • Mukesh Joshi
  • thymeless

    Is that a ROM or an offiicial release? Have you installed a more recent version of gapps if ROMMed?

    YOu might try deleting the cache and data for the Play store as well. Or sometimes I’ve read of people with such troubles on a custom ROM that have to delete their google ID off the phone, delete data and cache, for playstore, reboot, then add their google ID back on.

    • geiko

      It’s official. I had to delete all stored data to fix it. Thanks for the help.

  • da9el

    I had the same problem and it was fixed after a factory data reset.

  • qwertyman44

    try installing an old version by downloading apk

    • Raylen Dart

      Do anyone know how to fix the Google Play Store. It keeps on crashing and I don’t know why

  • fox

    here’s the fix:

    settings>>application manager>> all tab>>

    scroll to the bottom

    you’ll notice google/downloads is disabled

    enable it.

    This is the fix

  • singanina

    Thanks, it works x

  • leathergloves

    Download manager was disabled! It worked! But what disabled it?

  • Lucy

    OMG thank you thank you thank you!!!!!!!!

  • Navdeep Kaushal

    Thanks friends
    can u send ne a facebook request

  • Prasoon Tiwari 1

    LOL most of the comment are from guests … Dude If you like this then why don’t you join Androidandme ? We always want to increase our brotherhood … I hope you will join soon …

  • cris

    i tried your procedure to fixed it. But unfortunately its the same. Should i make my s3 to factory data reset?

  • cris

    i tried to fixed it by your procedure. But unfortunately its the same. Should i make my s3 to restore data reset?

  • pliu.2014

    Wait a while because the new playstore is coming out that might come to fix it.

  • francis dunn

    Hey thnxx a lot bro hrlped me alot……

  • Chelle

    Whaa .. what will I do .. after updating my s3 mini,my play store never always say google playstore has stopped .. then my phone seldom hanged ..

    • pliu.2014

      they have a new play store that you can download try it out.

  • IN076776

    Its working yipeee

  • yea boy

    Yea I went here to post it too but seems someone beat me to it :) id definitely reccomend making sure your download manager is enabled but you do some reset :D

  • azza

    Thanks ..fixed mine too :)

  • Irene

    omg! worked for me too! Thanks a lot!!!

  • je

    A million thanks!

  • Vickie

    You rock!!! This was driving me insane for months…thanks!!

  • norakvitiya

    When download some of game it sudenly closed it and it cant open even i do the three step

  • simon moore

    Fox you are legend

  • Simply Amazying

    You are great.Your process worked.

  • JAllen

    Best fix ever! I was freaking out.

  • adiw88

    YOU ARE LEGEND!!! i’ve been freakin out with my samsung s3 and now it all fixed! thanks mate..keep it simple and straight forward!

  • Hemant Barman

    So good of you bro…. This worked…. Thanks a lot… :)

  • shady

    im having the same issue but i cant find any enable/disable feature in my application manager…..

  • phatbouyinc

    Top man snm

  • josephCruz

    My playstore doesn’t work its really bugging me I did everythimg

  • joana

    Pliz my playstore isn’t working help me. Need it fast if u can help me email me to fast!

  • sam

    When I go into settings I don’t have application manager the only thing I see is apps and I did whatever I could do I even undownloaded the updates to the store

    • afs

      Go to setting/apps/ all/ Download manager/ an then enable. I just did it and its work :) I dont find this app at the end but in list on letter D (Download Manager)

  • Jim1984

    Dude just leave all the crap and try this one out and tell me if your issue is solved.

  • Jim

    I love Android phone but not much comfortable with touch screen.. I am using MOBOGENIE an amazing Android Manager with which we we can manage entire Android phone right from the PC.. send sms using pc key board , download apps using pc internet and much more
    it is free and can be downloaded from

  • Jim1984

    So Better, use Mobogenie available

  • Sandra Dee Ortega

    My Google playstore ap on my tablet wont let me get into it, when i click on it just crashes. Where do i go and fix the problem

  • John Kane

    Thank you it worked for me as well.

  • lyza

    wow thanks a lot i was trying to figure it out the whole morning good thing i tried looking it up here. :)

  • LuckyGuy

    thanks a bunch! it’s fixed! She’s so impressed I fixed it I might get lucky tonight!!

  • twin tigers

    I have same issue.I tried everything on my tablet but still it sucks…
    Need help………

  • Sid
  • Asif

    Thanks bro. Your solution worked like charm.

  • Wesley Dorsey

    Thank you so much! I was stumped worked like a charm. Thought I was in for a long search for the solution. Thank you!

  • Anthony

    Please i need help. My zte avid 4g has been rooted and the play store does not work please help. All phones are different so please! Help!!

  • Anthony

    I reset my phone,as well

  • xave

    Accidentally I pressed the disable button in the settings on application manager, pressed google play. I followed the instructions on what to do but I accidentally pressed the disable button and now I dont know what to do help!!

  • starsxoglitter

    Omg thank you bunches :D

  • masamune

    No dice for me …it keeps crashing

    Background data = enabled
    Download manager = enabled

    Plus force stop and clear cache …and it still crashes. :(

  • Chalky

    Thanks. It helps a lot.

  • Junaid

    Nexus S keeps rebooting.
    The power buttons stopped working on my Nexus S so i installed AnyUnlock application for using Volume button for Powering on the mobile. After two days my mobile got reset automatically and after that it keeps rebooting. Now I cannot go into Settings to do factory reset, nor I can use “power and Volume” buttons combination to root the mobile.
    I have important data in the built-in storage card which i want to recover.
    HELP !!!

  • Sophie Naughton

    Thank you so much! I’ve put off fixing my google play app because I thought I would have to reset/restore my phone but now it works and I didn’t have to do that! it was so simple thank to you, thank you! youre amazing.

  • Lynette Djong


  • Armandas Galkus

    Hey. When I open my play store it allways just show no connection retry :( please help me

  • bEn-G

    It worked normally after I reset apps preferences on Settings/App Manager . . .

  • chirag

    i forced stopped the google play store once and then i got an updated version of grand. now the phone hangs a lot and i cant operate it at all….any app crashes before opening….there is a notice displayed every 10 seconds that the google play has crashed….can someone help?

  • nipunali

    Ohh hoooooo –after updating my s3 mini,my play store always say google playstore has stopped .. then my phone seldom hanged ..Thanks

  • zered

    it really helps me to solve that problem on my sisters phone.. thanks..

  • Joe

    It works for me!! Thank you very much, I’ll translate for spanish SEO google.

    Error al abrir PLAY STORE en SAMSUNG GALAXY GT-I9100 con Android Version 4.1.2.

    Se solucionó con el vídeo de @Lee:



  • mohit

    Superb and Accurate.

    Same was happening in my HTC One S device…… need for factory reset………….

    Awesome Man :)

  • soley yuth hang

    It kind of like a little help for me thank
    I thought i have to reset factory data

  • Suraj Pandey

    Thanks a lot buddy. It worked.

  • Guy

    Oh thx dude finally its working I LOVE U >,<

  • Sandeep Shradhye

    Thanks a lot buddy. It worked.

  • steve

    Thanks it really works!

  • jerome santos

    i have my nexus 7 .. then it makes me disappoint because the playstore of this gadget always stop when anytime i search or browse an apps to be installed…

  • jerome santos

    i have my asus nexus 7 … it makes me dissapoint because the playstore of this gadget always stop when anytime i search or browse an apps to be installed..

  • gary

    when I use google play on my table tkroos g6 pad android inside its says unfortanetly google play stop working

  • uncle sam

    If the Download Manager is already enabled. try disabling it and then clear cache, also force stop. Then start the play store again.

  • jynker

    Please help.
    My samsung s3 mini . Cant play games after i downloaded it on play store . please give a fix.

  • linchpin

    can’t play games and videos and also can’t install some apps it always says unfortunately the apps has stopped working I need help pls

  • linchpin

    can’t play games and videos and also can’t install some apps on my s3 mini it always says unfortunately the apps has stopped working I need help pls.

  • Parvez Hussain

    I’m using HTC One X version Android 4.1.1. My Play Store has stop unexpectedly & i have tried by going to Manage Apps & then Clearing Caches then Force Stop. But it did’nt work out.

    Pls Help,
    Thank You.

  • Dani

    Hi, I just bought an android 4.5 and google play will not work!! It keeps saying ‘server error’ and then crashes, even though I am connected to my home internet. My download manager is already enabled, and I have tried disabling and then re-enabling it several times, and nothing! Please help!!

  • guy

    All google services crash on my s3 I’ve tried factory reset, reinstall, clear data. I’ve spent ours looking for a fix to what I believe (going by no. of posts on the subject) is an inherent Google problem. I give up!

  • Jimmy Dev

    Oh! my Android phone always hangs due to GTA VC. Any solution?

  • harry

    Hi. My phone Google app not working pls help me s3 mini

  • lina

    My samsung 4s was rooted after that my playstore stopped working I restored my mobile severel time and its still the same I cant even install apps anymore :((

  • Bishnu Dev

    Same problem with me too. Any solution?

    Blogger SEO

  • geekfreak

    I can’t find and application manager. Is that labeled as Apkmamager?

  • 1mobiles

    Discover the latest ANDROID apps and games. FREE and enjoy instantly on your Android phone.

    Search over 800000 Android Apps & Games

  • Dongamingz

    hi guys.. iv got a rooted galaxy s2. not bricked at all. my google app store got deleted. i factory reset and it didnt come back so i downloaded a apk. installed it fine but anytime i try accessing it it keeps crashing. even when im not trying to acces it it claims that google play store has stopped unexpectedly iv tried cleaing data and cache iv done a factory reset but not working iv gone to download manager and its enabled not disabled but still not working :( i need help this has never happened please dont repeat any steps iv mentioned as iv tried it and not working