AT&T Galaxy S3 won’t boot into clockworkmod recovery

Posted Aug 12, 2012 at 1:11 pm in Threads > Smartphones & Tablets

I have the AT&T variant of the GS3. I have tried to flash cwm recovery so i can root and install custom roms on my device. but every time i flash cwm, i still get stock recovery. I’ve tried using different computers and such to flash with odin. each time i have the yellow com sign, and it says pass but it still only boots stock recovery. does anyone have any solution to this problem? or a way to root my phone without installing cwm so i can do it via rom manager? any help is greatly appreciated. thank you very much guys

  • LukeT32
    • CJ LaFleur

      I followed that guide to the letter and it doesn’t work.

  • CJ LaFleur

    Has anyone else had the same problem?

    • Zorsik

      I’m having the exact same problem. I have International GT-I9300. Following every tutorial rechecking every step 20 times.

  • Chris Lewis

    To be honest you are better off posting at xda, or some other developer sight as they will be better able to help you with your problem. My advice would be to just follow the instructions to the t. You can also try redownloading all the files you are flashing as you might have a bad download. Im not sure what else to say because i have the vzw variant with the locked bootloader and we have different processes.

    Good Luck!!!

  • Chris Lewis

    On second thought… How are you trying to flash CWM???

    My process for the vzw phone was to flash a pre rooted file with oden, download rom manager, flash CWM, and boot into CWM to flash custom roms.

    If you aren’t using rom manager to flash it thats what I would suggest. Just download the free one, flash for your SPECIFIC device and then click boot into recovery.

  • CJ LaFleur

    i fixed it. I was flashing CWM through Odin. I had installed an OTA update from AT&T (big mistake), and it changed the process. if anyone has my problem, when you flash CWM, UNCHECK auto reboot and pull the battery when it flashes. it works fine. i’m now running CM10 and i have to say i coukdn’t be happier. Google now makes siri look like a dried up, otdated old hag lol

    • Mike C

      I’m having the same issue. I tried your fix and it’s still going to Android Recovery. Did you find a guide for the fix on XDA? Maybe I am missing a step. I Uncheck Auto Reboot and Reset Time and once it says PASS I unplug it and pull the battery. Then I try to reboot into Clockwork but it just goes right back to Android Flasher.

    • budderhog

      That worked! I was crying and lashing out a nearby loved ones. I was on my tenth recovery flash round. But pulling the battery before reboot totally worked! Thanks!

    • cav

      I spent the whole #### day trying to install a custom rom on my phone because lately the stock system wasnt functioning properly.
      I had problems trying to install it, as I didnt know at a time that the device must be flashed.
      When I finally figured it out I realize no matter what flash file did I use (CWM o TWRP) with Odin, the result was just the same.
      But after reading this I tried unchecking the auto-reboot. Then after the flash was completed I proceeded to remove the cable, then the battery and waited for a couple seconds. Then Reinserted the battery and booted it up in Recovery Mode. It finally got TWRP to work on my phone.

      (As a sidenote, I failed a couple of times to unpress the buttons to enter the TWRP recovery mode so I ended up having to do the whole process a couple of times…)

      • cav

        BTW, Thank you really much for the tip.
        My phone also is a S3 and my phone carrier is from Guatemala.

    • inder

      bro many thanks it worked like charm for me.

  • DJR

    @ CJ LaFleur 08/15/12 8:15 AM

    Man thanks so friggin much about posting ur last comment on here, i have been searching days and no one understood what the hell i was talking about,
    i too update to the latest OTA Update but from TMOBILE and we just received it yesterday (well i did) and CWM wouldnt install for the life of me, i thought i screwed something up lol IMEI or something haha.

    Flashed with ODIN agian, latest CWM Touch, deselected AUTO REBOOT and F. Reset TIme, waited for it to PASS installation, pulled battery and BAM it workd!! :)

    thanks a ton!

  • controlsfreek

    I have the sprint version, flashed CWM with odin, and when i do the volume up + home + power key combo, the screen stays black and it never gets to CWM. I’ve held the key combination for quit a long time with no luck. also tried the no-reset-battery-out bit with no luck. Anyone else seen this?

    I can hit the power button and the phone powers up and boots normally.


    • LukeT32

      Download ROM Manager or some other app from the market that allows you to boot to recovery.

    • clearzero

      Try releasing just the power button once you feel the first vibration. Hold the other 2 till CWM pops up. That is what I have to do on my TMO version.

  • hradek422

    CJ LaFleur’s process worked perfectly for my VZW i535. Thank you sir.

  • vamp

    lol. Anyone else pull the battery (which worked perfectly by the way! and the screen stayed on? I had the battery in one hand and the device in the other and the screen was still on! I thought residual power at first but it wouldn’t go away. Must have been powered by the USB. lol, Freaked me out!

  • balaram boddeda

    I wasted 2 and half hours guys..
    Thank you very much.. it worked like a charm.. :)

  • pandalink

    Worked like a charm after about 5 tries using other posted process. One clarification, after you get the “PASS!” in Odin, you can disconnect the USB cable and then pull the battery. Or as vamp states above, leave it connected to USB, and pull the battery, You’ll then have to disconnect the usb to to get it to shut off.

  • pandalink

    Another update. As stated above, I got it to work with the battery removal trick. However, the next time that I went through a normal shutdown and startup into recovery mode, the phone brought back the stock Android recovery! I still have the factory Android OS loaded in the phone. It is almost as if the factory OS looks to see what it’s recovery pointer is, and sets it back to the factory setting as the phone shuts down. When the battery is pulled, it obviously doesn’t have this opportunity, and the Clockwork recovery comes up. But when it is shut down normally, it resets the default Android recovery before shutting off. Does anyone else see this behavior?

    I have a Galaxy S3 T-Mobile…

    • DennisMenaceThe

      I have a T-Mobile GS3 as well and I run into that same problem. It’s a hassle to try to flash ROMs from my sd card because it keeps going to the phone’s stock recovery.

      Did you figure out why it’s doing that? how to stop it?

  • Zorsik
  • 9klas

    Didn’t actually think pulling the battery would work, but it did! THANKS!!!

  • Scree

    Ok so I tried every ones solution of switching reboot off pulling battery out after Odin installs but it only corrupted the install.

    However Leaving reboot on and letting it reboot then pulling battery out to switch off, then putting battery back in and then holding keys down to get into clockwork worked. Weird but worked for me :)

  • Scree

    Just to add to what I said I held down volume up and down at the same time and only let go of power button leaving both volume up and volume down held. If i left go of volume up and only held volume down it would not work.

  • colombianhusker

    THANK YOU!!! After 5 hours it is finally working!