Netflix Error 15001

Posted Oct 02, 2013 at 11:24 pm in Threads > Entertainment

I have the new nexus 7 with 4.3 build number JSS15R. Netflix still not working I’ve clearing data, clearing cache & uninstall as well. Still it doesn’t work at all anybody have any luck with a fix.

*Update* I just did a factory reset to see if it would fix it and still nothing that error code comes up.

  • SGB101

    Try an older version, ever since
    4.2 Netflix hasn’t worked for me (also 4od app) I’m using a modified 1.8.1apk it’s liking the latest features but works.

    Il link to it, it is my personal account so i can guarantee the app is safe. If you use it let us know how you get on

    • anil

      thanks a lot buddy..u made my life easier. i just bought nexus 7 only to watch movies using netflix.however, its not working. i copied your link and downloaded …magic!!! it worked!!!!! yeahhhhhhhhhh!
      thank u so much!

  • uknowme

    I know it’s not for everyone but I rooted mine. Netflix works right. If your interested I’m running stock by Scrossler on XDA.

  • dregin

    This drove me so completely nuts that I went and wrote a little blog post on how I got it running.

    Netflix on android is a joke!

    See my fix here:

  • Nick Burdett

    Hi, I just got a nexus 7 and found the issue you are all describing.

    I tried all the things suggested but none worked.

    I then connected to a different WiFi, using my phone as a hot spot, and logged in just fine. Then when going back onto the original WiFi connection it still works.

    Hope this helps.


  • cavster63

    I did a system’s update, which I found here:

    This fixed the problem to my nexus 7 2

  • SGB101

    4.3 has no issues with Netflix, so we no longer need the modded apk.

  • linda

    All I did is download the 4.4 update and it works great

  • Darren

    Setting the time and date to automatic worked for me. This seems to currently be the top suggestion on the Netflix support page.